Investigating template
Incident Report for Applicant Tracking Software
Resolved
All impacted services have recovered and are fully available. This issue has been resolved.
Posted Jun 14, 2018 - 07:28 PDT
Investigating
We are investigating availability issues with our app. The system is slow and unstable. Further updates will be provided as the investigation continues.
Posted Jun 14, 2018 - 07:22 PDT