Slowness in Loading of Documents
Incident Report for Applicant Tracking Software
Resolved
Functionality has been fully restored.
Posted Oct 16, 2019 - 10:28 PDT
Identified
Some users may encounter some lag when loading up documents or generating offer letters. We are aware of this issue and it is being investigated into. Our sincerest apology for any inconvenience this has caused.
Posted Oct 16, 2019 - 09:51 PDT
This incident affected: Offer Letters.