Increased Error Activity
Incident Report for Applicant Tracking Software
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 10, 2018 - 08:53 PDT
Investigating
We are currently seeing elevated error rates for some customers and are actively investigating. Further updates will be provided as the investigation continues.
Posted 2 months ago. Sep 10, 2018 - 08:22 PDT
This incident affected: Careers page, Offer letters, Message templates, Form builder, and Background checks.